Wind Deflectors For Folding Mirrors

mattyredvan

Member
VIP Member
Hi all,

Can someone tell me which (if any) front wind deflectors are suitable for vans with folding mirrors? I've searched the forum and read a lot of posts but can't find the answer. I like the Heko ones but the sale listing for them says they are not suitable for folding mirrors?

Thanks in advance.
 

Loz

California 204 DSG 4Motion MY17
VCDS User
Admin
Moderator
VIP Member
I have the factory deflectors (the ones that use trim tape and go on the outside of the door frame) and they are also fine with the folding mirrors.
 

Ayjay

Senior Member
VIP Member
T6 Guru
FWIW, I had Dubflecta sleeks on mine and have now fitted the Retro version as I prefer the look. Neither have any issue with the folding mirrors on my MY18 Highline.
 

mattyredvan

Member
VIP Member
Update:
I have fitted Heko style ones (I thought they were branded Heko, but they don't seem to be branded - Ebay purchase, didn't fully read the listing). Great fit, simple to install, no issues with the folding mirrors. Thanks for the replies. Cheers.
 

GONA66

Senior Member
VIP Member
T6 Pro
20191127_100707.jpg Just fitted a pair of tinted wind deflectors from TRAVELIN LITE , fitted in 2 minutes £25 delivered, perfect fit and I've folding mirrors ! :thumbsup:
 

Stefan

Member
View attachment 55862 Just fitted a pair of tinted wind deflectors from TRAVELIN LITE , fitted in 2 minutes £25 delivered, perfect fit and I've folding mirrors ! :thumbsup:
Mine were Travelin Lite too, as you say, perfect fit in minutes and can I recommend them too.
Just fitted a pair of the same wind deflectors from travelin lite and I seem to have quite a bit of wind noise coming from what it seems the glass doesn't seal properly where the supplied clips are holding the deflector. Do you guys experience the same issue ? I've fitted them according to their instructions and all good except the noise..
 

mattyredvan

Member
VIP Member
Just fitted a pair of the same wind deflectors from travelin lite and I seem to have quite a bit of wind noise coming from what it seems the glass doesn't seal properly where the supplied clips are holding the deflector. Do you guys experience the same issue ? I've fitted them according to their instructions and all good except the noise..
I haven't noticed any increase in wind noise at all I don't think. Are you sure you have pushed the clips in fully and the glass is going all the way up? That's the only thing I can think of. I fitted another set of these today on a different van, but haven't driven it yet so I can't confirm if these are "quiet" also.
 

Stefan

Member
I haven't noticed any increase in wind noise at all I don't think. Are you sure you have pushed the clips in fully and the glass is going all the way up? That's the only thing I can think of. I fitted another set of these today on a different van, but haven't driven it yet so I can't confirm if these are "quiet" also.
I double checked and they are pushed all the way up and glass the same when shut
 

GONA66

Senior Member
VIP Member
T6 Pro
Just fitted a pair of the same wind deflectors from travelin lite and I seem to have quite a bit of wind noise coming from what it seems the glass doesn't seal properly where the supplied clips are holding the deflector. Do you guys experience the same issue ? I've fitted them according to their instructions and all good except the noise..
Hi, mind are as quiet as a mouse ! to coin the phrase , i'd suggest taking them off and re-fitting them . have you made sure the clips are the correct way round ? …..just a thought :)
 

Salty Spuds

Senior Member
VCDS User
VIP Member
T6 Legend
I had Hekos on my van. No problem with the mirrors, but they were noisy in the wind & made the horrendous “A” pillar blind spot even worse. They’re sat on my desk if anyone wants to make me an offer.
 

Skyliner33

Senior Member
VCDS User
VIP Member
T6 Legend
Just fitted a pair of the same wind deflectors from travelin lite and I seem to have quite a bit of wind noise coming from what it seems the glass doesn't seal properly where the supplied clips are holding the deflector. Do you guys experience the same issue ? I've fitted them according to their instructions and all good except the noise..
I replaced my OEM wind deflectors with Heko ones. I get the same wind noise. I’m sure it’s because of the metal clips not allowing the window to move fully up and seal. I’m thinking of trying them without the clips.
If my OEM ones hadn’t broken on removal I would be tempted to go back to them although they don’t look anywhere near as good they were much quieter.
 
Top