Press studs noise

RML

Member
May be just a newbie silly question but I just installed a complete set of curtains in my Multivan. I love the way they look but the loose press studs make a continuous jingling noise while driving that I find really annoying.
I have thought of placing a drop of silicon grease or something like that to keep the metal ring inside the stud from making noise while keeping its function but I'm not sure if it may work and I'm afraid of making a mess if it melts with Summer heat.
Keeping them buttoned may sort the noise but they blind more space of the window that way and I would prefer to keep them undone.
Have any of you found a solution for this? Or may be it's only me that I find it annoying...
 

Kind of Blue

Senior Member
T6 Guru
May be just a newbie silly question but I just installed a complete set of curtains in my Multivan. I love the way they look but the loose press studs make a continuous jingling noise while driving that I find really annoying.
I have thought of placing a drop of silicon grease or something like that to keep the metal ring inside the stud from making noise while keeping its function but I'm not sure if it may work and I'm afraid of making a mess if it melts with Summer heat.
Keeping them buttoned may sort the noise but they blind more space of the window that way and I would prefer to keep them undone.
Have any of you found a solution for this? Or may be it's only me that I find it annoying...
Can you use Velcro instead?
 

RML

Member
It’s the inner metal ring inside the female stud. The part that “opens” to get engaged with the male stud.
 

Texxaco

Senior Member
VIP Member
T6 Guru
Why don’t you place a small amount of Vaseline inside the female press stuff. That should stop the rattling @RML
 
  • Like
Reactions: RML

DXX

Senior Member
VIP Member
T6 Legend
It sounds to me like the fasteners are not quite pressed together tight enough.
It’s easy to tighten them up with a punch / die kit like this
OR make do with a centre punch / pin punch and a cloth pad.
 

RML

Member
Thanks to all!
This was the problem:
The problem is that the ring inside the female stud vibrates causing the noise:
F7347162-1CE5-4F44-98F7-4F8549D23AB5.jpeg
I decided to go with the silicone grease option and apply a very small amount in each stud.

A1DDC6C1-F9E0-41E4-BD26-016327E67504.jpeg
7317D288-574A-4BC2-8650-1EE216B6DD3F.jpeg
Solved!
 
Top